UnsatisfiedLinkError exception loading native library: njni11
                                                 Last update (2012-05-02 11:32:37)
                                                                                                                   Date added (2012-05-02 06:40:52)

Summary
When running Autoconfig for Oracle database 11.2.0 with R12.1.3 i get the error:
UnsatisfiedLinkError exception loading native library: njni11
java.lang.UnsatisfiedLinkError: /lib/libnjni11.so: ld.so.1: java: fatal:
/lib/libnjni11.so: wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)
Oracle Support says that ORACLE_HOME 11.2 does not contain 32-bit libraries, but Autoconfig still uses a 32-bit Java version. You must use 64-bit Java.

Solution
1. Apply patch latest TXK patch. For R12.1.3 Patch 7651166
2. Migrate the code from the APPS-Tier to the DB-Tier via the appsutil.zip
3. Check that appsutil has all the required subdirectories (for example scripts, if not copy them from the old appsutil!)
4. Create the Database Context File again
perl $ORACLE_HOME/appsutil/bin/adbldxml.pl 
template=$ORACLE_HOME/appsutil/template/adxdbctx.tmp 
out=/u01/clone/db/tech_st/11.2.0/appsutil/CLONE_ebs6.xml

5. Run Database Autoconfig
Reviews
Filters
Search